Personal tools
You are here: Home Calcul Technique Documentation IBM cluster iDataPlex - ANTARES Mises à jour d'Août 2013

Mises à jour d'Août 2013

Document Actions
Ce qui change : il faut parfois recompiler son application.

Les points suivants sont IMPORTANTS : À LIRE !

  1. Les commandes "source" à taper (ou à mettre dans un fichier ~/.bash_profile (et non ~/.bashrc)) pour activer les environnements (pour la librairie Open MPI ou pour l'application OpenFOAM par exemple) restent inchangées. Les scripts de soumission restent aussi inchangés.

  2. De nouvelles versions de compilateurs et de librairies MPI sont installées :
    • Compilateur Intel : la version 13.1 remplace les versions 11.1 et 12.1
    • Compilateur Gnu : la version 4.4.6 remplace la version 4.1.2
    • Librairie Intel MPI : la version 4.1.0 remplace les versions 4.0.0 et 4.0.3
    • Librairie Open MPI : la version 1.4.3 remplace la version 1.4.2
    • Librairie Intel MKL : la version 11.0.3 remplace la version 10.2

    Les codes compilés régulièrement (quelle que soit leur nature) doivent donc être entièrement recompilés.

    Si vous utilisiez "export I_MPI_FABRICS=shm:dapl" ou "export I_MPI_FABRICS=dapl" avec Intel MPI sur l'ancien système, nous vous conseillons de recompiler votre code et de supprimer cet environnement à l'exécution.

    L'installation faite d'Open MPI 1.4.3 ne supporte pas l'hybridation MPI / OpenMP (niveau de support : "MPI_THREAD_SINGLE").
    Pour l'hybride MPI / OpenMP, utilisez Intel MPI (niveau de support complet : "MPI_THREAD_MULTIPLE").

  3. Si vous utilisez MKL, recompilez en vous référant aux nouvelles modalités décrites dans :
    • /soft/makefiles/MKL/README
    • /soft/makefiles/MKL/MakeMkl*

  4. Les codes liés à une librairie NetCDF de /soft/library doivent être recompilés : suivre les instructions des README mis à jour dans l'un des répertoires /soft/library/netcdf-4.1.1, /soft/library/netcdf-4.1.1-hdf5, /soft/library/netcdf-4.1.3, /soft/library/netcdf-4.1.3_Gnu4.4.6 .

  5. Si vous avez compilé sur l'ancien système un code que vous ne développez plus, vous pouvez tenter de l'exécuter à nouveau sur un cas ayant déjà fonctionné :
    • s'il ne fonctionne plus sur ce cas, recompiler après avoir sauvegardé l'exécutable initial
    • s'il fonctionne, il n'est donc pas nécessaire de le recompiler ; une recompilation pourra éventuellement améliorer un peu ses performances (étant donné les mises à jour de version des compilateurs et librairies MPI)

  6. Le bon fonctionnement sur le nouveau système des logiciels suivants, mutualisés ou restreints aux groupes propriétaires, a été vérifié :
    • Gaussian
    • Jaguar
    • Gamess
    • Quantum Espresso
    • Amber9
    • NAMD
    • CHARMM
    • Gromacs
    • OpenFOAM
    • Code Aster (version 10.3 séquentielle)

    Les utilisateurs de Jaguar doivent commencer par supprimer leur fichier ~/.ssh/known_hosts avant de soumettre à nouveau ce logiciel (procéder une seule fois à cette suppression).

    Si vous utilisez un autre logiciel mutualisé (ou restreint à votre groupe) installé dans /soft, et constatez un problème, contacter support@crihan.fr .
    Tester au préalable un cas ayant fonctionné sur l'ancien système.

Powered by Plone CMS, the Open Source Content Management System

This site conforms to the following standards: